
Advanced OCR 
 
 

High Tech Center Training Unit 
 

of the California Community Colleges at the 
Foothill-De Anza Community College District 

 
21050 McClellan Road 
Cupertino, CA 95014 

(408) 996-4636 
(800) 411-8954 

 
www.htctu.net 

 

 

 
 

URL to our CC license: 
http://creativecommons.org/licenses/by-nd-nc/1.0/ 

 
Creative Commons website: 
http://creativecommons.org 



 

www.htctu.net ii Rev. April 27, 2010 

Table of Contents 
Basic Workflow.................................................................................................................1 
Creating the Image File .....................................................................................................2 
Abbyy FineReader.............................................................................................................2 

Interface .................................................................................................................... 2 
Toolbar Set-up .......................................................................................................... 3 
Options Set-up .......................................................................................................... 4 

Document Tab ...................................................................................................... 4 
1. Scan/Open Tab.................................................................................................. 5 
2. Read Tab........................................................................................................... 6 
Important! ............................................................................................................. 7 
3. Save Tab ........................................................................................................... 7 
View Tab .............................................................................................................. 8 
Advanced Tab....................................................................................................... 9 
Spell Checker Settings........................................................................................ 10 

Processing an Image (TIFF or PDF) File................................................................ 11 
Step One: Open an Image File or a PDF File ..................................................... 11 
Step Two: Analyze Layout ................................................................................. 12 
Step Three: Adjust Areas.................................................................................... 12 
Step Four: Read Document................................................................................. 13 
Step Five: Check Spelling .................................................................................. 14 
Step Six: Save the Document ............................................................................. 15 

FineReader Tips...................................................................................................... 16 
Automating Tasks ................................................................................................... 17 

Creating an Automated Task .............................................................................. 17 
OmniPage Pro .................................................................................................................24 

Interface .................................................................................................................. 24 
Document Manager................................................................................................. 24 
Configuration for Blind User.................................................................................. 25 
Toolbars .................................................................................................................. 28 
Options Set-up ........................................................................................................ 29 

OCR Tab............................................................................................................. 29 
Process Tab......................................................................................................... 30 
Proofing Tab ....................................................................................................... 31 
General Tab ........................................................................................................ 32 
Text Editor Tab................................................................................................... 33 
Scanner Tab ........................................................................................................ 34 

Processing an Image (TIFF or PDF) File................................................................ 36 
Step One: Load a File ......................................................................................... 36 
Step Two: Run the OCR..................................................................................... 36 
Step Three: Adjust Zones ................................................................................... 38 
Step Four: Save the Document ........................................................................... 42 

OmniPage Tips ....................................................................................................... 47 
 



 

www.htctu.net 1 Rev. April 27, 2010 

Basic Workflow 

 1. Remove spine from book. 
 2. Separate pages in book page-by-page (have pages at least six inches apart—glue 

can be transparent and stretchy!!). 
 3. As you separate the pages, get a sense of the book, and choose a few 

representative pages—note if there are pages that may require different scanner 
settings—sticky notes help make it easy to return the pages later. (For easy books, 
1 page may be enough, and usually 6 or so is plenty.) 

 4. Scan those pages. 
 5. Run OCR on pages. 
 6.  If you’re getting more than one recognition error per page, go back and adjust the 

scanner settings. 
 7. Rerun steps 4–6 until the recognition errors drop. (As an aside, I find that most 

people go too quickly through the scanning step and do not get a good scan—the 
result is hours and hours of editing later!) 

 8. During the test-OCR phase, use your test pages to create a template for the book 
in your OCR program (OmniPage or FineReader). 

 9. Scan the book—usually in chapters, but you may scan the entire book, depending 
on your policies/procedures. 

 10. Open the TIFF files in a review program (Microsoft Office Document Imaging 
software works well and is free)—rescan any pages that did not scan well. 

 11. OCR the book using the template you created. 
 12. Edit the book in your OCR program. 
 13. Save your OCR files, as well as any formats you create. 
 

BASIC WORKFLOW CHECKLIST  

Remove book spine  

Separate pages  

Choose a few representative pages  

Scan test pages  

Run OCR on test pages  

Adjust scanner settings if needed  

Create a template  

Scan the book  

Review the scanned files  

OCR using the template  

Edit  

Save  
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Creating the Image File 

Although you can scan with either OmniPage or FineReader, we recommend that you 
scan your files to TIFF, using the scanning utility that comes with your scanner, and 
then work with the resulting multipage image. There are a number of reasons: it 
preserves the TIFF files for later use with other applications, it prevents problems with 
crashing in the middle of scans, it allows you to take full advantage of the options that 
are built into your scanner. Please note that you can combine multiple scanned files 
(TIFF and JPEG, etc.) within the OCR program. 

Abbyy FineReader 

ABBYY USA  
47221 Fremont Boulevard 
Fremont, CA 94538  
510-226-6717  
www.abbyyusa.com 
 

Interface 
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Toolbar Set-up 
Go to View > Toolbars. Turn on the Quick Access Toolbar. 
 

 
 
Go to View > Toolbars > Customize Toolbars…. Set the Categories to “Image,” and 
find the Eraser tool under Commands. Click the double-headed arrow to move the 
eraser tool onto your Quick Access Toolbar. 
 

 
 
Choose View > Customize Toolbars. Move the Order Areas icon onto the Quick Access 
Toolbar. 
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Options Set-up 
In the menus, go to Tools > Options or use the keyboard shortcut CTRL + Shift + O. 

Document Tab 

Under the Document tab, you can choose the languages that are in your document. 
Click the Edit Languages button to access mathematical and scientific options. 
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The more precise you can be about the languages in a document, the better your 
recognition will be. Remember to include “Greek” whenever you process math so that 
you recognize the Greek letters (like pi) that are used as mathematical symbols. 
 

 
 

1. Scan/Open Tab 

Make sure that “Do not read and analyze” is unchecked. You want to be able to control 
what FineReader does, not have it start automatically. Do enable the image 
preprocessing. That feature allows FineReader to deskew and enhance the scanned 
image (or PDF). If you have two pages per image page, you can choose “Split dual 
pages.” It is better to rotate the pages yourself, rather than asking FineReader to do so. 
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2. Read Tab 

Under the Read tab, you can choose the reading mode (Thorough) and opt to train the 
patterns of unusual fonts. 

 

 
 

FineReader now behaves much more like OmniPage with its ability to train recognition 
of unusual fonts. In order to use this feature, make sure that “Train user pattern” is 
selected. To load an already established pattern, select “Use user pattern.” Below are the 
instructions from the FineReader help menu. 
 
1. Select Tools > Options… and click the 2. Read tab.  
2. Select Train user pattern under Training.  
3. Click the Pattern Editor… button.  
4. In the Pattern Editor dialog box, click New….  
5. In the Create Pattern dialog box, type in a name for your new pattern and click OK.  
6. Close the Pattern Editor and the Options dialog boxes by clicking the Close button 

in each.  
7. On the toolbar at the top of the Image window, click Read. 
8. Now if ABBYY FineReader encounters an unknown character, a Pattern Training 

dialog box will display the unknown character.  
9. Teach new characters and ligatures. 

 A ligature is a combination of two or three "glued" characters (for example, fi, 
fl, ffi, etc.). These characters are difficult to separate because they are "glued" 
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during printing. In fact, better results can be obtained by treating them as single 
compound characters. 

Note: Words printed in bold or italic type in your text or words in superscript/subscript 
may be retained in the recognized text by selecting the corresponding options under 
Effects. 
To go back to a previously trained character, click the Back button. The frame will 
jump to its previous location and the latest trained "character image-keyboard character" 
correspondence will be removed from the pattern. The Back button will function only 
within one word. 

Important! 

 You can only train the system to read the characters included in the alphabet of the 
recognition language. To train ABBYY FineReader to read characters that cannot be 
entered from the keyboard, use a combination of two characters to denote these non-
existent characters or copy the desired character from the Insert Character dialog 
box (click to open the dialog box).  

 Each pattern may contain up to 1,000 new characters. However, avoid creating too 
many ligatures, as this may adversely affect OCR quality. 

 

3. Save Tab 

Under the Save Tab, you can access settings for particular formats. 
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You can set the options for how FineReader will save documents into different formats. 
For Microsoft Word, you can retain the page breaks, if you wish. Please note that it is 
generally best to use Formatted text for the layout, rather than Exact Copy or Editable 
Copy, which may result in text boxes. 
 

View Tab 

Under the View tab, you can now choose whether to see thumbnails or details in the 
document window. For those using screen readers, I would recommend using the 
Details panel. 
 

 
 

Both views can be adjusted to include exactly the information that you want to show. 
Click the Customize button. 
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Note that in the combo box at the bottom of the page, you can choose which colors to 
use for highlighting uncertain characters, non-dictionary words, etc. 
 

Advanced Tab 

On the Advanced tab, you usually do not want to open the last FineReader document at 
startup. 
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Spell Checker Settings 

Under the Spell Checker Settings button, you can uncheck the "Stop at words not found 
in dictionary" option if you will be spell checking anyway later in Word. If you will not 
be taking the document into Word, then go ahead and turn on the dictionary. Note that if 
FineReader is not quite getting the spacing around punctuation correct, you can adjust 
the setting in this window. 

 

 
 

You can also choose specialized dictionaries in this tab by selecting the View 
Dictionaries button. Note that if you are running OCR on a science text related to 
medicine, biology, or chemistry, it is good to turn on the English Medical Terminology. 
Similarly, if you are working on a business or legal text, you may receive better results 
by loading the English Legal Terminology. 

 

 



 

www.htctu.net 11 Rev. April 27, 2010 

Processing an Image (TIFF or PDF) File 
Step One: Open an Image File or a PDF File 

Click on the Open icon or use File > Open or use the keyboard shortcut Ctrl + O. 
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Step Two: Analyze Layout 

Use the Analyze Layout option (Document > Analyze Layout or Ctrl + Shift + E) first 
on complex layouts then read the pages. This workflow reduces the chance of the 
program crashing and allows layout adjustment without running OCR more than once.. 
 

 
 

Step Three: Adjust Areas 

Use the tools to add to or delete areas (formerly called blocks). To reorder zones, right 
click and turn on the Area Properties. It will display at the bottom of the image window. 
To change the reading order, simply change the number after the # sign. 
 
Tip: To see more of the page, turn off the Area Properties by right-clicking on the 
image and deselecting “Area Properties.” 
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Step Four: Read Document 

Go to Document > Read Document or use the keyboard shortcut Ctrl + Shift + R.  
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Step Five: Check Spelling 

Go to Tools > Check Spelling. If you wish to change the settings for the spell checker, 
you can click on “Options.” 
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Step Six: Save the Document 

File > Save As > Microsoft Word Document 
 

 
 

Note that you can adjust your settings for a specific format by clicking on “Options.” To 
avoid text boxes, save the layout as “Formatted Text.” 
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FineReader Tips 
Zoom window: FineReader has a zoom window (View > Zoom Window) that allows 
you to enlarge selected areas of the image or text. 
Stop spell check: To tell the program just to find OCR errors and not unknown words, 
go to Tools > Options > Check Spelling. Uncheck "Stop at words not found in 
dictionary.". 
Document, Page, or Area: Controls are now broken out under menu choices based on 
the size of the overall section that you want to work on. To apply a command to the 
entire document, look under Document on the menu bar. When you wish to work on an 
individual page, look under Page, etc. 
Eraser: The eraser tool allows you to edit the underlying TIFF file by deleting pixels 
(i.e., changing black to white). If you wish to save the changes, go under File to Save 
Images.  
 
The eraser tool is now located under Page > Edit Page Image or use the shortcut keys 
Ctrl + Shift + C. The image for the page you are on will open in a new window titled 
Edit Image. 
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Automating Tasks 
You can now set up workflows in Abbyy FineReader. 

Creating an Automated Task 

As an example, we will create a workflow to OCR TIFF files that are in a folder and 
then save the files as a FineReader file. All files will be saved in one FineReader batch. 
1. Start the Automation Manager (select Tools> Automation Manager or Ctrl + T). 
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2. In the Automation Manager dialog box, click the New button on the toolbar. 
 

 
 
3. In the Automation Wizard dialog box, click the desired step from the list of steps 

in the left-hand pane. The selected step will be displayed in the right-hand pane. 
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Click Change… to change the properties of the step. In this case, click Change and then 
Browse to find the folder containing the files you wish to process. 

 

 
 

 
 

 
 
If you want to be able to make adjustments to the layout, then save the document right 
after analyzing the layout. 
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If you simply want to read the document and save it, choose Read. 
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4. Once you have added all the necessary steps to your automated task and selected 
their properties, click Finish. 
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OmniPage Pro 

Nuance 
1 Wayside Road 
Burlington, MA 01803 
781-565-5000 
www.nuance.com  
 

Interface 

 
 

Document Manager 
Of the two OCR programs, OmniPage is the more accessible for someone who is blind, 
and the main reason for that is the document manager.  As a sighted-user, I generally 
prefer to work with it off, since I do not want to allot the screen space to it. For a quick 
check to see exactly where the program is in the OCR process, however, it can be very 
useful. 
 
Alt V + N will toggle the document manager on and off. It appears at the bottom of the 
window, and the area can be modified by dragging the horizontal bar at the top of the 
pane. 
 
The document manager is completely accessible with screen readers (JAWS, Window-
Eyes, SuperNova, etc.) and will give you a lot of information about your OmniPage 
document. You will need to configure it, however, or else it will provide a lot of 
confusing, extraneous information. 
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Configuration for Blind User 
The directions below are written to be usable by someone who is blind or sighted. 
 
OmniPage includes four possible views:  
1. The thumbnail images: This view shows thumbnails for each page and allows easy 
mouse navigation from one page to another. Once in this pane, you can also navigate 
with the arrow keys. 
2. The page image: This is the original image of the document.  Both the page image 
and thumbnail image are part of the “Image Panel.” This panel is optional for a blind 
user. 
3. The text editor: This view shows the text after OCR has been run. 
4. The document manager: This view provides a great deal of information about the 
document, and it is fully accessible to screen readers and refreshable Braille displays. 
 
All of these views can be turned on and off under the View (Alt + V) menu on the menu 
bar. Please note that the F6 key will move you from one pane to the next. 
 
To configure the document manager, you need to go under the View menu to 
Customize Columns ( Alt V + C). 
 
The default at the beginning is to have all the columns on. This is not helpful; in fact, 
some of them show icons, which is totally useless for someone who is blind. 
 
I recommend just using the first six columns on the list: 
Status 
Characters 
Suspect words 
Reject characters 
Words 
% Accuracy 
 
You may find that you want to add other columns later as you get used to working with 
the program. 
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If the screen reader does not immediately start reading the choices in the choice box, Alt 
+ C should move the focus to that window. These are check boxes, so you can use your 
space bar to select and deselect. 
 
Mostly, you will want to deselect. Leave the first five selected then go through the list 
and deselect the rest. The down arrow key will move you properly from one to the 
other. 
 
A minor point, but once you have deselected the rest of the long list, you might want to 
use your up arrow (just hold it down until you hear “Status”) to go back to the top of the 
list. The columns are set too narrow for a sighted person to read the column labels, and I 
do not know whether every screen reader will read them configured like that or not.  
 
You can reset the sizes as follows: 
With the cursor on the column name (for instance, Status is the first column name), go 
to the Column Width edit box (Alt + W). Type in 100 (the unit is pixels). Alt + C will 
move you back to the column list and you can arrow down to the next column name and 
repeat the process.  
 
If you are using a Braille display, you may want to play with the column sizes a bit 
more to get a precise fit. The 100 pixel width is just a rule of thumb. For a more precise 
fit, try starting with these settings: 
Status: 67 pixels 
Characters: 68 pixels 
Reject Characters: 103 pixels 
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Words: 48 pixels 
Suspect Words: 87 pixels 
 
One more refinement: I would recommend going to the “Reject Characters” choice and 
move it up (Alt + U). Now arrow down to the “Words” choice and again move it up 
(Alt + U). This order change allows you to hear total characters followed by suspect 
ones and then total words followed by suspect words, which gives you a sense of how 
well-recognized the page was. Too many errors, and you may need a better scan. 
 
Make sure to say OK when all of this is done. OmniPage will remember the settings, so 
you should only need to do all this once. 
 
If your focus is not in the Document Manager pane, use the F6 key to navigate to the 
proper pane. 
 
As the screen reader reads across the row in the document manager, you will hear the 
page number where your focus is, then the status, then the characters on the page, the 
number of rejected characters, the number of words on the page, and the number of 
suspect words. 
 
You can use the arrow keys to move from page to page. 
 
You may find that you need even fewer columns than I’ve suggested, but these five are 
a nice starting point for you to experiment with.  
 
As an example of one way to use the document manager, you may have recognized 
(i.e., run OCR) on a portion of the document and then stopped. At a later time, you want 
to resume processing the document. 
 
To find out where you left off, you would move down the list until you find a page that 
has not been recognized. It will say acquired (meaning that the image file is present but 
OCR has not yet been run). 
 
Starting at the first one that says “Acquired,” hold down your shift key and use your 
down arrow until you have selected all the pages in the document. 
 
Once the pages have been selected, use Control + 2 to run the OCR. 
 
I like to run the OCR separate from the proofreading, as I believe that combining the 
two leads to more crashing. 
 
If the two are still linked, that is, if the proofreading window opens while the OCR is 
still running, then change your options. Go to Tools and Options: Alt T + O. In the 
Options window, go to the Proofing tab. Uncheck the second checkbox on the list, 
“Automatically proofread results after OCR.” Then say OK. 
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Toolbars 
To help you become accustomed to using the shortcut keys, turn on the shortcut keys on 
the toolbars: View > Toolbars. Check the Show ToolTips and Show Shortcut Keys in 
ToolTips checkboxes. 
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Options Set-up 
In the menus, go to Tools > Options or use the keyboard shortcut Alt + T + O. 
 

OCR Tab 

The OCR tab allows you to select the languages that are included in a document. If you 
are working on a foreign language document, you can choose English, as well as the 
foreign language. Choosing a foreign language allows the program to recognize that 
letters in that language that use diacritical marks (umlauts, cedillas, accents, etc.). If you 
are processing a math book, turn on Greek so that the Greek letters (alpha, pi, theta, 
etc.) used in mathematics will be recognized. Be sure that you only select the languages 
that you need, however, as the program will look for (and find!) the letters used in those 
languages. 
 
If you are processing a document that has a great deal of financial, legal, or medical 
terminology, be sure to turn on the professional dictionary for that subject. Please note 
that you can also load custom dictionaries if there is a great deal of unusual vocabulary. 
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Process Tab 

The OCR tab allows you to specify where to add pages to the OmniPage document if 
you have somehow skipped a page during scanning or need to add a page that needed to 
be rescanned. Make a TIFF file of the page to add and then set the option in this 
window prior to inserting it. Note that you can set the option to “before current page” if 
you need to insert a page in the middle of the document. 
 
Make sure to set the “Page rotation” option to “None.” You can manually rotate a page 
if you need to, and the program does not do a good job of analyzing orientation. 
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Proofing Tab 

Depending on whether or not you will run a spell check later during your workflow, you 
may check or uncheck the “Mark all non-dictionary words” option. If you will be 
running a spell check in MS Word, you can leave this uncheck. 
 
Make sure to uncheck “Automatically proofread results after OCR.” You can launch the 
proofreading window automatically, and there are other methods for proofreading your 
document that you may prefer using. 
 
If you wish to use the IntelliTrain feature, you will need to use the proofreading 
window. IntelliTrain remembers the corrections that you have made and looks for 
patterns that the program can apply to better recognize unusual fonts. It makes most 
sense to use IntelliTrain if you are processing a book in sections. You can load the 
IntelliTrain data from a previous section before processing the next one, ensuring better 
recognition. If you use this feature, check the box to prompt to save. If you are not using 
the feature, then uncheck that box. 
 
You can load IntelliTrain data from a previous file by selecting the three-dot browse 
button. 



 

www.htctu.net 32 Rev. April 27, 2010 

 
 

General Tab 

There are a number of useful features on this tab, depending on how you use your 
program. You can add OmniPage to your system tray for quick access. You can enable 
update detection to make sure that you always have the latest versions. We will not be 
using any of the features in this tab for this class. 
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Text Editor Tab 

Under Show, mark sure that “Headers and Footers” is unchecked. Otherwise, OmniPage 
will attempt to automatically detect these features, and you cannot easily access them—
either to include the page number or to reorder the zone. It also will not include the 
header or footer when you save out to Word, which means that page numbers will be 
lost. 
 
Make sure to check “Reading Order.” If this feature is not checked, you will not see the 
reader order of the zones (i.e., which zone comes before which other zone) or reorder 
them. 
 
If your text in the text editor pane ever looks funny (running off the screen), check to 
make sure that “Wrap to Ruler” is turned on. Having it on is the default, so this should 
not be an issue. 
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Scanner Tab 

We do not generally recommend using OmniPage for scanning; however, if you need to 
do a great deal of color scanning, you might wish to use if. If you do use OmniPage for 
scanning, make sure to install the actual scanning program for your scanner in 
OmniPage. You can embed the drivers that came with your scanner in the OCR 
program. Do not use the generic drivers that came with OmniPage. Even using this 
technique, you may find a loss of speed and features scanning through OmniPage. 
Unless you have a compelling reason to scan through this program, stick with using the 
scanning utility that comes with your high speed scanner. 
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Processing an Image (TIFF or PDF) File 
Step One: Load a File 

 
 

Step Two: Run the OCR 

Be sure to select the pages before running the OCR. Click on the first thumbnail and use 
CTRL + A to select all. 
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Step Three: Adjust Zones 

Use the "on-the-fly" tool to redraw zones.  

 
 
To reorder zones, right click in Text Editor view and change reading order. You may 
need to ungroup the zones first. Right click and choose ungroup. 
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Next right click and choose, “Change Reading Order.” You will now see numbers 
showing the order of the zones. 
 



 

www.htctu.net 40 Rev. April 27, 2010 

 
 
Right click again and choose “Define Reading Order.” Your numbers will now 
disappear, and you can click on the zones in the order that you wish to have them read.  
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When you are satisfied with the order, right click one last time and select “Apply 
Order.” 
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Step Four: Save the Document 

Make sure to set the view for your text editor to “Formatted Text View” before you 
save. The setting is under View > Text Editor Views or the buttons at the bottom left of 
the text editor pane.  
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When you save the document, you have a number of options. You can save the text in 
MS Word or other text formats. You can save the document as a graphical PDF or a 
TIFF. You can also choose “save as multiple” and save to Word and PDF or Word and 
TIFF at the same time. 
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If you have a PDF document that you want to convert to TIFF, you can load the file into 
OmniPage and then jump directly to “save as” (step 3), without running the OCR. Since 
you are essentially going from one graphical format to another, there is no point to 
introducing possible recognition errors by running OCR. The only reason to run the 
OCR would be if you wanted to delete portions of the document before saving it to 
TIFF. 
 
If you are saving to Word and you do not want any textboxes, you will need to remove 
the “retain drop cap” option. After selecting Microsoft Word as the file type to save, 
click on the “Options” button. Scroll down until you see the “Retain drop caps” 
checkbox and uncheck it. Note that you can check the “Make changes permanent” 
button if you want to change the default.  
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Also note that you have a choice of saving the entire OmniPage file to one document, 
saving individual pages as separate documents, and other variations. 
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OmniPage Tips 
Shortcut: To see the shortcut keys associated with menu items, go to View > Toolbars 
and check "with shortcut keys." 
On-the-fly zoning: You can now modify zones without having to reimage the entire 
page. For small changes, click on the "on the fly" button. 
Stop spell check: To tell the program just to find OCR errors and not unknown words, 
go to Tools > Options > Proofing and uncheck "Mark non-dictionary words." 
Reordering zones: You can reorder the zones in the text editor window; however, it 
must be set to True Page view (View > Text Editor Views > True Page). If the zones are 
locked, right click and choose the "ungroup" option. Then choose "change reading 
order" and "define reading order." 
Verifier: A zoom window, called the verifier, is included in the text editor view. Click 
on show/hide verifier or use F9 while in the text editor window. 
Saving: Note that you can save one document as individual pages, save multiple 
documents into one, or save each image as one document. Be aware of which you 
choose. 
Formats: For PDF, use True Page. For Word, use Flowing Page or Retain Fonts and 
Paragraphs. 
Batch manager: The batch manager is the new scheduler for running OCR, converting 
documents, etc. Note that you can also cancel a scheduled job through the batch 
manager. 
Templates: For books with a standard layout, you can create a template specifically for 
that book. 
Speech: OmniPage will read text to speech as well as responding to verbal commands 
in some of the windows. 
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